Page 1 of 1

Cannot create new modification

PostPosted: Tue Jan 10, 2017 1:02 am
by chrisjake
I have a new registered XL version 5.3.1 and cannot create a new modification.

I'm familiar with the process as I've added plenty of new call signs in the old version for FS2004. I now have FSX and I went to add a new modification with XL version 5.3.1 and whether I just click on the new modification button, or do a Control-N, nothing happens. I did notice that when I click on the new modification button my SAVE and UNDO buttons become active, but nothing else appears.

How can I get to the screen that allows me to add my own modifications?

Any help is appreciated.


Re: Cannot create new modification

PostPosted: Tue Jan 10, 2017 1:20 pm
by Lars
Strange, I have not heard of this problem before, and I can't reproduce it on my own system.

Does this happen for all the different modification types? so:
My Modifications/Aircrafts/Manufacturers
My Modifications/Aircrafts/Models
My Modifications/Airports/Agent Names
My Modifications/Airports/ICAO
My Modifications/Phraseology
My Modifications/Telephony Designators

Can you create a modification by selecting
My Modifications/Telephony Designators/Missing Telephony Designators
and then clicking the button:
Start creating a new modification in EditVoicepack

If you pres the "New modification" button (and the undo button becomes enabled), what happens if you save and restart EditVoicepack - do you then have a modification "NEW"?

Re: Cannot create new modification

PostPosted: Thu Jan 12, 2017 1:59 am
by chrisjake
It works fine for both Aircrafts/Manufacturers and Models

It does NOT work for either of the Airports - Agent Names or ICAO

it works fine for Phraseology

It does NOT work for Telephony Designators.

I tried what you suggested and still cannot make a modification with a new entry. The only way I can make modifications in the Telephony Designators is by using one of the many duplicates I have. I can open a duplicate call sign and alter it to something new.

If I highlight Telephony Deignators and click on the New Modification button, it does expand the Telephony "folder" to show all the call signs, it just doesn't give me a new modification page.

** I also tried highlighting Missing Telephony Designators, but when that is highlighted, the New Modification button is not active to click.

Re: Cannot create new modification

PostPosted: Thu Jan 12, 2017 2:34 am
by chrisjake
I just discovered something!

I was scrolling through the Telephony Deisgnators to get an idea of how many duplicates I had, and I came across 20+ instances of the call sign "New". When I click on that there it is.....the new modification screen.

So it looks like every time I clicked on the New Modification button it did create a new one - it just didn't present the screen in front of me. So at least it works, I just wonder how to get the new modification screen to come to the top.

Re: Cannot create new modification

PostPosted: Fri Jan 13, 2017 8:51 am
by Lars
Do you have a lot of modifications? It might be influenced by how many modifications are visible in the treeview on the left. I did notice it has a bug when there are a lot of items expanded in the tree on the left- if the selected item is positioned quite far from what is currently visible it can loose track of which item is selected. Unfortunately this is not something I can easily fix- the control is part of the .NET Framework.

As a workaround, you can enter "NEW" in the search box to at least find the node.

Re: Cannot create new modification

PostPosted: Sat Jan 14, 2017 12:27 am
by chrisjake
Yes, I do have a ton of modifications. it all makes sense now as I have a ton of modifications in the other area where its going to the bottom.

While its a slight pain-in-the-arse, I'm just glad its working! All the "NEW" modifications go to the very bottom so its easy to just click to create 20-30 modifications, then just scroll down to the bottom and start working on all the NEW's. It can get addicting!

Thanks for a great tool.


Re: Cannot create new modification

PostPosted: Sat Jan 14, 2017 11:24 am
by Lars
There is one potential workaround.

If your callsigns are registered ICAO callsigns (as opposed to military etc) you can upload them to my server. If they pass my detailed *cough* scrutiny I'll include them in the community modifications and you can delete the one you have in the My Modifications branch. :)