Page 1 of 1

can't run EVP after new installation

PostPosted: Fri Oct 13, 2017 7:28 pm
by Timgig

After a complete new installation of FSX, i can't run EVP XL. (I have tried both Versions: FSX and FSX Steam Edition)

I can start the EVP programm, but when i click on the "update Flight Simulator..." button, the program shows "starting update process..."
then, the program freezes and a Windows window shows "EditVoicepackUpdateProcess funktioniert nicht mehr".

I tried also an older Version of the EditVoicePack.
Here abort the Installation with this error message:

System.BadImageFormatException: Die Datei oder Assembly "System.Xml, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089" oder eine Abhängigkeit davon wurde nicht gefunden. Im Modul wurde ein Assemblymanifest erwartet.
Dateiname: "System.Xml, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089"
bei System.Uri.ParseConfigFile(String file, IdnScopeFromConfig& idnStateConfig, IriParsingFromConfig& iriParsingConfig)
bei System.Uri.GetConfig(UriIdnScope& idnScope, Boolean& iriParsing)
bei System.Uri.InitializeUriConfig()
bei System.Uri.InitializeUri(ParsingError err, UriKind uriKind, UriFormatException& e)
bei System.Uri.CreateThis(String uri, Boolean dontEscape, UriKind uriKind)
bei System.Windows.Forms.ThreadExceptionDialog..ctor(Exception t)
bei System.Windows.Forms.Application.ThreadContext.OnThreadException(Exception t)
bei System.Windows.Forms.Control.InvokeMarshaledCallbacks()
bei System.Windows.Forms.Control.WndProc(Message& m)
bei System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
bei System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

WRN: Protokollierung der Assemblybindung ist AUS.
Sie können die Protokollierung der Assemblybindungsfehler aktivieren, indem Sie den Registrierungswert [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) auf 1 festlegen.
Hinweis: Die Protokollierung der Assemblybindungsfehler führt zu einer gewissen Leistungseinbuße.
Sie können dieses Feature deaktivieren, indem Sie den Registrierungswert [HKLM\Software\Microsoft\Fusion!EnableLog] entfernen.

************** Geladene Assemblys **************
Win32-Version: 2.0.50727.8762 (QFE.050727-8700).
CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll.
CodeBase: file:///D:/Games/FSX/MyTraffic/ATC%20MODIFICATIONS/AtcVoicepackInstaller.exe.
Win32-Version: 2.0.50727.5491 (Win7SP1GDR.050727-5400).
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/
Win32-Version: 2.0.50727.8770 (QFE.050727-8700).
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/
Win32-Version: 2.0.50727.5495 (Win7SP1GDR.050727-5400).
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/
Win32-Version: 2.0.50727.5483 (Win7SP1GDR.050727-5400).
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Accessibility/
CodeBase: file:///D:/Games/FSX/MyTraffic/ATC%20MODIFICATIONS/Bevelstone.EditVoicepack.InstallerApi.DLL.
Win32-Version: 2.0.50727.8762 (QFE.050727-8700).
CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll.
Win32-Version: 2.0.50727.5420 (Win7SP1.050727-5400).
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms.resources/

Google found nothing to this...

I tried to run as administrator, compability Windows XP.

I have also repair the Installation of Net.Framework.

Can anybody help me?

Re: can't run EVP after new installation

PostPosted: Sun Oct 15, 2017 7:15 am
by Lars
There is definitely something wrong with some system files - an error in EditVoicepack should not be able to cause System.xml (which is part of the .NET framework) to fail loading.

Please go through the steps 1-3 in the section "If you can’t install, uninstall or start EditVoicepack":

If it does not help, please provide additional information:
1) Which version of Windows are you running?
2) It seems it has a file loaded from MyTraffic (AtcVoicepackInstaller.exe) which is somewhat surprising - I would not expect that to be loaded when you run EditVoicepack XL directly. Can you please confirm you do not have the MyTraffic installer running? And if there is any MyTraffix related programs you can stop while running EditVoicepack, please do so.
3) Please click the "Support" button on the main menu if EditVoicepack. Then click "Upload to support" and post the upload ID you get back here. This is a rather large upload though, so it will only work if you have reliable and relatively fast internet.

Re: can't run EVP after new installation

PostPosted: Wed Oct 18, 2017 7:03 am
by Timgig
Thank you for the answer.
I run the program on Windows 7.

I have gone through all the steps from the Support section, without success.
All programs were terminated at the start of Editvoicepack XL.
Always the same problem.

Now i uploaded the files to the support.
The upload ID is: D5A-DDG

I have worked with EVP for many years. Only now, after a new installation, the problem occurs.

I hope, we can find a solution....

Re: can't run EVP after new installation

PostPosted: Fri Oct 20, 2017 5:02 am
by Lars
I am planning to look at it this weekend.

Re: can't run EVP after new installation

PostPosted: Sat Oct 21, 2017 8:33 am
by Lars
Unfortunately it does appear to be a system error as I expected, not a problem with the EditVoicepack installation.
The name:
System.Xml, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089
is the correct name of a system DLL that must be present.

Unfortunately as a programmer I am "just a user" of the system - and if the system is broken, I do not have any detailed knowledge on why it breaks and how to fix it. All I can do is google the error and hope someone else found out.

The only additional step I can think of is to enable extra logging in the .NET file loader. It is a bit technical, and there is no promise it will show any information that can be used. But it is still worth trying. The top answer to this stackexchange questions shows which registry keys must be set to enable this: ... ion-in-net
Enable logging per the instructions, run EditVoicepack and force the error once, then disable the logging again (set the values back to their original value, so write them down).

Once this is done zip up the content of the folder you used for logging and email it to and I will do my best to assist, but - jut to make it clear - this is a system error, I can't promise I can fix errors outside EditVoicepack.